php zip در سی پنل

در مرکز محتوای سرور دات آی آر

 

وب‌سایت‌های PHP که از فایل‌های فشرده استفاده می‌کنند به پسوندهای فشرده برای پردازش داده‌ها نیاز دارند.

چرا به پسوند PHP zip نیاز داریم؟

صاحبان وب سایت همیشه به دنبال راه هایی برای بهینه سازی فایل های وب سایت هستند. فشرده سازی یکی از راه های کاهش حجم فایل است.

فرمت فایل بایگانی zip از فشرده سازی داده بدون از دست رفتن ، پشتیبانی می کنند و در نتیجه آن را برای ارسال و ذخیره داده ها مناسب می کنند.

اگر وب‌سایت‌ها از فرمت فایل فشرده استفاده می‌کنند، برای پردازش آن به پسوند zip نیاز دارند. یعنی پسوند zip به کاربران امکان خواندن و نوشتن در فایل های فشرده را می دهند.

چگونه پسوند PHP را در سی پنل فعال کنیم؟

1. ابتدا وارد cPanel می شویم و روی بسته های PHP PEAR موجود در قسمت SOFTWARE کلیک می کنیم. نماد مانند تصویر ظاهر می شود.

 

zip

 

 

2. سپس zip را در نوار جستجو تایپ می کنیم و Archive_Zip در دسترس خواهد بود. در اینجا، بر روی نماد نصب کلیک می کنیم.

3. پس از نصب Archive_Zip به مرحله قبل می رویم و روی نماد Select PHP Version کلیک می کنیم.

4. اکنون، Archive_Zip در اینجا قابل مشاهده است. روی چک باکس افزونه zip کلیک کنید و دکمه ذخیره را بزنید تا Archive_Zip به نسخه فعلی PHP اضافه شود. با این کار پسوند PHP Zip نصب می شود.

چگونه پسوند PHP را در WHM فعال کنیم؟

افزونه Zip امروزه یک نیاز بسیار اساسی برای وب سایت ها است. بنابراین ما آن را در تمام سرورهایی که مدیریت می کنیم فعال می کنیم. بیایید ببینیم چگونه آن را از طریق WHM فعال می کنیم.

برای این منظور میتوانید ابتدا مقاله کامندها و اطلاعات PHP در سرور WHM را مورد مطالعه قرار دهید.

در ابتدا وارد WHM می شویم و به صورت زیر حرکت می کنیم:

Software >> EasyApache 4 >> Customize >> PHP extensions

در اینجا zip را جستجو می کنیم و phpx.x-php-zip را برای همه نسخه ها فعال می کنیم. در نهایت بر روی Review and Provision کلیک می کنیم.

این افزونه zip را برای تمام وب سایت های PHP در سرور فعال می کند.

خطاهای رایج هنگام فعال کردن پسوند PHP Zip
اکنون، بیایید چند خطای رایج را که هنگام فعال کردن پسوند PHP گزارش شده را ببینیم:

1. کتابخانه گم شده است.

خطاهای رایج:

PHP ZipArchive Library is missing or disabled

میتوانید با استفاده از کامند زیر این مورد را بررسی کنید:

php -v

او از CentOS 6 با آپاچی و PHP 7.0 استفاده کرده است. PHP 7 یک بسته php7.0-zip ارائه می دهد. ما آن را با استفاده از کامند نصب کردیم:

yum install php7.0-zip

از کامند زیر برای بررسی کتابخانه ها استفاده میکنیم:

yum list installed | grep -i php

در نهایت کامند زیر را برای راه اندازی مجدد آپاچی اجرا کردیم.

service httpd restart

در نهایت این خطا رفع میشود.

2. خطای کامند نصب

پسوندهای PHP را می توان از طریق دستورات نیز فعال کرد. بنابراین، تعداد کمی از کاربران سعی می کنند آن را از طریق خود دستورات نصب کنند. اما اشتباهات در کامند منجر به خطا می شود.

در اینجا یک مثال است که در آن کاربر به دلیل کامند نادرست با خطا مواجه شده است.

خطای کلاس ZipExtension یافت نشد را دریافت کرد. او از CentOS 7 و PHP 7.0.27 استفاده کرده است.

yum install php70-php-pecl-zip

بسته واقعی php-pecl-zip.x86_64 بود. بنابراین ما آن را با استفاده از دستور نصب میکنیم:

yum php70-php-pecl-zip.x86_64 را نصب کنید.
و سپس با اجرای کامند آن را فعال میکنیم:

echo “extension=zip.so” >> /etc/php.d/zip.ini
این خطا رفع شد و پسوند PHP فعال شد.

اشتراک گذاری در linkedin

به تیم متخصص ما اعتماد کنید!

کد تخفیف مخاطبین مرکز محتوا:

Blog01

از این کد می‌تونید برای خرید اشتراک خدمات سرور مجازی و هاست استفاده کنید و از %10 تخفیف تو سفارش این خدمات بهره‌مند بشید!

محتوای پیشنهادی شما

محتوای مقاله مفید بود؟

0 0 رای ها
این مقاله چطور بود؟
اشتراک در
اطلاع از
0 دیدگاه
بازخوردهای آنلاین
مشاهده همه دیدگاه ها