نصب Python and Ruby Selector

Ruby Selector

در این مقاله پیرو مقالات مرتبط با ماژول ها افزونه های موجود برای سیستم عامل CloudLinux به معرفی و آموزش نحوه ی نصب افزونه های Python و Ruby Selector می پردازیم.

همانطور که در گذشته در مورد افزونه ی PHP Selector توضیح دادیم. این افزونه به گونه ای رفتار می کرد پس از نصب آن تمام نسخه های رایج PHP در اختیار شما بود و می توانستید نسخه ی مورد نظر خود را برای هاست های مختلف موجود بر روی سرور انتخاب نموده و تنظیمات لازم را انجام دهید.

Python و Ruby Selector نیز به همینگونه می باشند و نسخه های مختلف این زبان ها را برای سرور شما فراهم می آورند که پس از نصب می توانید برای هر هاست و بصورت کلی بر روی سرور نسخه ها و تنظیمات مورد نظر خود را ست نمایید.

نسخه های Python که در این افزونه پشتیبانی می شوند:

alt-python27 2.7.9, supported by CloudLinux 5, CloudLinux 6, CloudLinux 7;

alt-python33 3.3.2, supported by CloudLinux 6, CloudLinux 7;

alt-python34 3.4.1, supported by CloudLinux 6, CloudLinux 7.

نسخه های Ruby که در این افزونه پشتیبانی می شوند:

Alt-Ruby 1.8;

Alt-Ruby 1.9;

Alt-Ruby 2.0;

Alt-Ruby 2.1;

Alt-Ruby 2.2;

Alt-Ruby 2.3;

Alt-Ruby 2.4.

برای نصب می توانید با توجه به اطلاعات سرور خود از کد های ارایه شده در ادامه استفاده نمایید. البته توجه داشته باشید که این موارد در واقع افزونه های برای سیستم عامل CloudLinux هستند در نتیجه برای نصب آن ها ابتدا می بایست این سیستم عامل بر روی دایرکت ادمین یا سی پنل شما نصب شده باشد.

برای نصب Python بر روی EasyApache3  :

yum install lvemanager alt-python-virtualenv alt-mod-passenger

بر روی EasyApache4  :

yum install lvemanager alt-python-virtualenv ea-apache24-mod-alt-passenger

و برای نصب نسخه های Python و Ruby برای Selector از کد های زیر استفاده نمایید.

yum groupinstall alt-python

yum groupinstall alt-ruby

سپس برای شناسایی کامپایلر های نصب شده توسط سرویس CageFS از دستور زیر استفاده نمایید.

cagefsctl –force-update

با دانشنامه Server.ir همراه باشید.